Computer freezing - could this be a RAM problem?

For discussing Linux compatible (or not) devices

Moderators: ChrisThornett, LXF moderators

Computer freezing - could this be a RAM problem?

Postby spottedcat » Wed Sep 13, 2006 9:49 am

Intermittent problem with self-build Pentium P4 machine with Aopen i915Ga-PLF m-board and matched pair of 500Mb DDR400s with multiboot setup. And, yes, I have got them in the correct slots; the POST screen shows 'Dual Channel Mode Enabled'.

I first noticed the problem after I installed Mepis 6. It repeatedly froze - mostly while using firefox - so solidly that I had to press the reset button to reboot. No response at all from keyboard or mouse. I thought it was an issue with Mepis and/or KDE and/or firefox because I started to get it with the Mepis 3.4 I had on another partition. Then Ubuntu did it a couple of times, and this morning Fedora 5 (with Gnome) froze solidly twice in quick succession, but now I've had it running (fingers crossed) for about an hour with no problem. I'm posting from the Aopen machine in Fedora.

I've run memtest for about half an hour with no errors reported, but it smells to me of a RAM problem. So - before I spend yet more money on replacement RAM modules, any thoughts please?

Thanks.
spottedcat
LXF regular
 
Posts: 971
Joined: Mon Oct 31, 2005 3:14 pm
Location: UK

RE: Computer freezing - could this be a RAM problem?

Postby nelz » Wed Sep 13, 2006 10:15 am

It could be a borderline power supply. Did you use a decent branded PSU or the unbranded one that came with the case. The latter are notoriously unreliable, despite any claims made about output.

Try disconnected all unnecessary peripherals. If the lockups abate, a PSU is the likely cause.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8497
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

RE: Computer freezing - could this be a RAM problem?

Postby spottedcat » Wed Sep 13, 2006 11:00 am

Interesting idea, but I think unlikely. It's a really swish Ultra-Quiet Q-Technology 400W PSU from quietpc.com. At least I hope that's not the problem. :( I was using it in another machine for quite some time with no problem, bought a 350W unit for that machine and swapped the 400W into the machine which is freezing. I'm sure 400W is more than enough for what I'm running.

Oh - and now the problem machine has been running OK for over two hours now. Strange.

Edit:, but then froze solid while using PCLinuxOS later this afternoon. That's 0.93 Big Daddy PCLinuxOS - I'm impressed.
spottedcat
LXF regular
 
Posts: 971
Joined: Mon Oct 31, 2005 3:14 pm
Location: UK

RE: Computer freezing - could this be a RAM problem?

Postby rattus » Thu Sep 14, 2006 12:33 pm

Something that may be worth trying is re-seating the ram sticks and graphics card.
rattus
 
Posts: 39
Joined: Mon Aug 28, 2006 11:05 am

Re: RE: Computer freezing - could this be a RAM problem?

Postby spottedcat » Thu Sep 14, 2006 6:41 pm

rattus wrote:Something that may be worth trying is re-seating the ram sticks and graphics card.


I thought of swapping round the two (allegedly) identical RAM modules - don't know why really, but it seems worth a try. So I'll do what you suggest as well. Thanks for that.
spottedcat
LXF regular
 
Posts: 971
Joined: Mon Oct 31, 2005 3:14 pm
Location: UK

Postby baasivan » Thu Sep 14, 2006 7:01 pm

Spottedcat
I had a similar problem using different late kernel distros on a particular PC. (Reset to unfreeze) I then discovered that Linux actually still ran under the frozen keyboard and screen. (I spotted some HDrive activity, some cron job?) Boot into failsafe and it would not freeze. The logs show nothing. Again a live distro like Knoppix would run without any problem.
baasivan
 
Posts: 8
Joined: Thu Jan 19, 2006 7:30 pm

Postby nelz » Thu Sep 14, 2006 8:22 pm

Could that have been X freezing? Did Ctrl-Alt-F1 work?
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8497
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby spottedcat » Thu Sep 14, 2006 11:19 pm

nelz wrote:Could that have been X freezing? Did Ctrl-Alt-F1 work?


Unfortunately, no. Ctrl-Alt-F1, F2 etc. Ctrl-Alt-Backspace. Ctrl-Alt-Del. Nothing. Frozen solid. :(
spottedcat
LXF regular
 
Posts: 971
Joined: Mon Oct 31, 2005 3:14 pm
Location: UK

Postby nelz » Thu Sep 14, 2006 11:32 pm

Not even Alt-SysRq-S/U/B?
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8497
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby spottedcat » Fri Sep 15, 2006 7:46 am

nelz wrote:Not even Alt-SysRq-S/U/B?


I haven't tried that one, mainly because I haven't heard of it before. What does it do? :oops:

I'll try it next time. Thanks.

baasivan, thanks for that information. I sincerely hope that's not the problem. :(
spottedcat
LXF regular
 
Posts: 971
Joined: Mon Oct 31, 2005 3:14 pm
Location: UK

Postby nelz » Fri Sep 15, 2006 8:36 am

See the FAQ box on the Answers pages of LXF 86 :)

The "magic sysrq" key combination of Alt-SysRq is intercepted by the kernel (unless disabled), press this in combination with a command key to get the kernel to do various things. The most useful keys are the three I mentioned

Alt-SysRq-S - syncs all discs
Alt-SysRq-U - unmounts all discs and remounts them read-only
Alt-SysRq-B - reboots the computer

The first two ensure that your discs are in a safe state before the reboot, which is an instant reboot, not a controlled shutdown. Your system has to be pretty broken for these to not work, either a major kernel oops or something sucking up so much CPU power that there's not enough left to handle these simple commands.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8497
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby spottedcat » Fri Sep 15, 2006 9:28 am

nelz wrote:See the FAQ box on the Answers pages of LXF 86 :)


Another first for Future Publishing I see. :D

Thanks, nelz. I'm in Mepis 3.4 (Mepis 6 was broken by the repeated resets) on the affected machine at the moment. I've taken a note of the key combinations and I'll give Mepis a couple of CPU intensive tasks and see what happens.
spottedcat
LXF regular
 
Posts: 971
Joined: Mon Oct 31, 2005 3:14 pm
Location: UK

Postby nelz » Fri Sep 15, 2006 10:23 am

Code: Select all
$ ls -l ~/lxf/PreviousIssues/86/Answers/FAQ.txt
-rw-r--r-- 1 nelz users 2.5K Aug 30 16:04 /home/nelz/lxf/PreviousIssues/86/Answers/FAQ.txt


Oh yes :)
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8497
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby spottedcat » Fri Sep 15, 2006 5:10 pm

nelz wrote:Not even Alt-SysRq-S/U/B?


Typical! It's taken most of the day to answer this one. The machine's been on for about 9 hours. First I prepared a tar.gz archive of my Ubuntu partition because of this. I want to do a system update later. If the update screws the installation I'll restore from the tarball. Then I left clamav chuntering its way through the many partitions for about 2-3 hours. But at last about 5 minutes ago it froze solid while using Firefox. (I was looking at Ubuntu forums. Any connection? :))

The answer, nelz, is no. Alt-SysRq-S - U - B doesn't do a thing. At least not in Mepis. The only other hardware complication is that I'm using a KVM switch, except that the other two machines never show this behaviour.
spottedcat
LXF regular
 
Posts: 971
Joined: Mon Oct 31, 2005 3:14 pm
Location: UK

Postby Rhakios » Sat Sep 16, 2006 12:46 am

As nobody has said this yet, and as I'm slightly drunk:

I don't think that the RAM is the problem, I think it's EWE!

:D
Bye, Rhakios
User avatar
Rhakios
Moderator
 
Posts: 7634
Joined: Wed Apr 06, 2005 11:18 pm
Location: Midlands, UK

Next

Return to Hardware

Who is online

Users browsing this forum: ferrari, Yahoo [Bot] and 0 guests

cron