Draftsight on Ubuntu 13.10 (Saucy)

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Draftsight on Ubuntu 13.10 (Saucy)

Postby gmport » Mon Oct 07, 2013 12:15 pm

I've been using Linux since Ubuntu 9.10 upgrading with each new release until Unity was introduced when I swapped to Mint. Now I'm starting to make friends with Unity having installed 64bit Saucy beta 2 on a USB HDD.

Everything is good apart from installing 'Draftsight' (only available in 32bit). As a retired draughtsman, I use it quite a bit and now can't really do without it.
My method of installation on Mint 15 64bit KDE was:
Code: Select all
sudo apt-get install ia32-libs libdirectfb-extra libxcb-render-util0
sudo dpkg --force-all -i ~/Downloads/draftSight.deb
sudo apt-get -f install

The result of entering the dpkg command is:
Code: Select all
~$ sudo dpkg --force-all -i ~/Downloads/draftSight.deb
[sudo] password for gm:
dpkg: regarding .../gm/Downloads/draftSight.deb containing dassault-systemes-draftsight, pre-dependency problem:
 dassault-systemes-draftsight pre-depends on libatk1.0-0 (>= 1.28.0-0)

dpkg: warning: ignoring pre-dependency problem!
dpkg: regarding .../gm/Downloads/draftSight.deb containing dassault-systemes-draftsight, pre-dependency problem:
 dassault-systemes-draftsight pre-depends on libcairo2 (>= 1.8.8-2)

dpkg: warning: ignoring pre-dependency problem!
dpkg: regarding .../gm/Downloads/draftSight.deb containing dassault-systemes-draftsight, pre-dependency problem:
 dassault-systemes-draftsight pre-depends on libdirectfb-extra (>= 1.2.7-2)

dpkg: warning: ignoring pre-dependency problem!
dpkg: regarding .../gm/Downloads/draftSight.deb containing dassault-systemes-draftsight, pre-dependency problem:
 dassault-systemes-draftsight pre-depends on libgtk2.0-0 (>= 2.18.3-1)

dpkg: warning: ignoring pre-dependency problem!
dpkg: regarding .../gm/Downloads/draftSight.deb containing dassault-systemes-draftsight, pre-dependency problem:
 dassault-systemes-draftsight pre-depends on libpango1.0-0 (>= 1.26.0-1)

dpkg: warning: ignoring pre-dependency problem!
dpkg: regarding .../gm/Downloads/draftSight.deb containing dassault-systemes-draftsight, pre-dependency problem:
 dassault-systemes-draftsight pre-depends on libpixman-1-0 (>= 0.14.0-1)

dpkg: warning: ignoring pre-dependency problem!
dpkg: regarding .../gm/Downloads/draftSight.deb containing dassault-systemes-draftsight, pre-dependency problem:
 dassault-systemes-draftsight pre-depends on libxcb-render0 (>= 1.4-1)

dpkg: warning: ignoring pre-dependency problem!
(Reading database ... 228319 files and directories currently installed.)
Unpacking dassault-systemes-draftsight (from .../gm/Downloads/draftSight.deb) ...
access control disabled, clients can connect from any host
access control disabled, clients can connect from any host
/var/lib/dpkg/tmp.ci/ShowLicence: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory
access control enabled, only authorized clients can connect
access control enabled, only authorized clients can connect
dpkg: error processing /home/gm/Downloads/draftSight.deb (--install):
 subprocess new pre-installation script returned error exit status 127
Errors were encountered while processing:
 /home/gm/Downloads/draftSight.deb

I assume this is a result of ia32-libs having now been deprecated.

libdirectfb-extra libxcb-render-util0, do seem to install correctly. Is there a fix for this or do I now have to revert to 32bit distros?

Regards gmport
gmport
 
Posts: 20
Joined: Fri Jan 20, 2012 3:16 pm

Missing information

Postby gmport » Tue Oct 08, 2013 7:40 am

After re-reading my post, I realise that I have left out what is possible the most important part of my explanation of the problem... my appologies.

The libraries:
Code: Select all
libdirectfb-extra  libxcb-render-util0

install ok, but ia32-libs fails with:
Code: Select all
~$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

E: Package 'ia32-libs' has no installation candidate

Installing the replacement packages 'lib32z1', 'lib32ncurses5' and 'lib32bz2-1.0' does not solve the problem. It does seem to be a missing 'ia32-libs' issue.
I would be very grateful for any suggestions for a workaround.

Regards gmport
gmport
 
Posts: 20
Joined: Fri Jan 20, 2012 3:16 pm


Return to Help!

Who is online

Users browsing this forum: No registered users and 5 guests