Highest resolution for most distros on my laptop is 800X600

Comments, suggestions and questions about Linux Format magazine and the coverdiscs

Moderators: ChrisThornett, LXF moderators

Highest resolution for most distros on my laptop is 800X600

Postby albion » Thu Sep 16, 2010 9:00 am

I have an eight year old Toshiba Satellite laptop with this specification:
CPU: Single core Celeron (Coppermine) (UP) cache 128 KB flags (sse) bmips 2190.72 clocked at 1095.362 MHz
Graphics: Card Trident Microsystems CyberBlade XPAi1 X.Org 1.7.6 Res: 800x600x60hz
256 MB RAM

Originally it had Windows 98 installed. Later I upgraded to Windows XP but of course it became very slow. I'd like to install a lightweight version of Linux so I can continue to use it just for word processing and going online. I've tried live discs of various distros, but with most of them the highest screen resolution is 800 x 600, leaving a one and a quarter inch black border surrounding the window. When running MS Windows the resolution was 1024 x 768, which fills the screen.

I take it the problem lies with the Trident CyberBlade graphics card.

Not all distros have a problem. Puppy Linux from your August disc installed running at 800 x 600, but I was then able to open a menu and select from various higher resolutions including 1024 x 768. Most distros don't allow that. But for other reasons I decided against Puppy.

As an experiment I ran Linux Mint 9 from the same August cover disc but of course it ran like a snail, and in 800 x 600 mode. However, when I booted it in compatibility mode the correct 1024 x 768 resolution was selected for a full screen display. So it can be done.

Here's a suggestion for a future Linux Format disc: a selection of small distros suitable for older PCs and laptops, each capable of being booted in compatibility mode, to get the required resolution. Distros I'd like to see included are Peppermint One and Lubuntu.

Also from your discs I've tried Slitaz – weirdly the resolution was too high and the buttons supposedly located bottom right were invisible because they were off the screen. I tried pressing Alt then dragging with the left mouse button but nothing moved. In the 'Step-by-step installation' article in June's Linux Format (p.41) it states that screen resolution and colour depth for Slitaz can be chosen during bootup, after selecting keymap. That doesn't seem to be the case.

I also tried Unity – resolution correct at 1024 x 768, but confusing and unfamiliar – too far from Ubuntu/Mint for me.

I downloaded iso images of Linux Mint 9 LXDE, Peppermint One, and Lubuntu – but all showed max. 800 x 600 resolution.

Is there any way round this problem?

I thought I'd found a remedy on one forum, explaining how to get the proper resolution with a Trident video card on Ubuntu:
http://ubuntuforums.org/archive/index.php/t-763964.html

But the instructions begin: Once it has booted up open up a terminal and enter sudo displayconfig-gtk
But when I did this I got the message that the command was not recognised. I tried it with Peppermint One, Lubuntu, and Mint 9 LXDE.

Any suggestions?
albion
 
Posts: 13
Joined: Wed May 28, 2008 12:24 pm
Location: East Sussex, UK

Re: Highest resolution for most distros on my laptop is 800X

Postby ollie » Thu Sep 16, 2010 10:41 am

albion wrote:I take it the problem lies with the Trident CyberBlade graphics card.


That's the problem - I don't think there has ever been a solution to Trident graphics chips.
User avatar
ollie
Moderator
 
Posts: 2749
Joined: Mon Jul 25, 2005 11:26 am
Location: Bathurst NSW Australia

Postby loebus » Thu Sep 16, 2010 1:01 pm

I haven't tried this [my graphics work]

But at the terminal type:
sudo apt-get install displayconfig-gtk

then try again with
sudo displayconfig-gtk

- Good Luck! -
User avatar
loebus
LXF regular
 
Posts: 165
Joined: Fri Apr 09, 2010 6:22 pm
Location: Here

Postby albion » Thu Sep 16, 2010 5:59 pm

Tried sudo apt-get install displayconfig-gtk

Got response: E: couldn't find package displayconfig-gtk

But thanks for the suggestion... it might have worked.

I'll just have to get used to working with 800x600 until a cover disc includes a suitable distro in compatibility mode. :(
albion
 
Posts: 13
Joined: Wed May 28, 2008 12:24 pm
Location: East Sussex, UK

SOLVED

Postby albion » Sat Oct 16, 2010 4:46 pm

Solved the problem after installing Moon OS - presumably this will work with other flavours of Ubuntu as well. This is the procedure:

Open terminal and enter:

gksudo gedit /etc/X11/xorg.conf

Then enter password.

You will then see a text editor with full editing rights (take care). It will show very basic resolution stuff contained in the xorg.conf file. Replace this with the following:

Section "Device"
Identifier "Trident Microsystems CyberBlade XPAi1"
Driver "trident"
BusID "PCI:1:0:0"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
Option "DPMS" "true"
HorizSync 30.0-60.0
VertRefresh 50.0-70.0
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768" "800x600"
EndSubSection

EndSection

Save the file and reboot. You will now find you have 1024x768 resolution filling the entire screen. Very Happy :D
albion
 
Posts: 13
Joined: Wed May 28, 2008 12:24 pm
Location: East Sussex, UK

Postby hecatae » Sun Oct 17, 2010 10:42 am

have you tried Mandriva?
User avatar
hecatae
 
Posts: 63
Joined: Sun Feb 25, 2007 10:22 pm


Return to Magazine and coverdiscs

Who is online

Users browsing this forum: No registered users and 2 guests