no search on lxf dvd's

Comments, suggestions and questions about Linux Format magazine and the coverdiscs

Moderators: ChrisThornett, LXF moderators

no search on lxf dvd's

Postby hendrik » Sun Apr 17, 2005 6:22 am

whenever i try to do a search on the dvd, i get a java (?) error message: "error parsing index file". This occurs on different boxes, with different browsers and java versions. (Suse 9.2, Mandrake 10.0, win98, Firefox, MSE)
The only cd-version i have (LXF57C) however, does perform well on a search.
Please anyone? :?:
hendrik
 
Posts: 7
Joined: Sun Apr 17, 2005 6:02 am

RE: no search on lxf dvd

Postby nelz » Sun Apr 17, 2005 7:57 am

This seems to be one of those things that affects some people yet works fine for others.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8553
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Re: RE: no search on lxf dvd

Postby mugstar » Wed Apr 20, 2005 10:39 pm

nelz wrote:This seems to be one of those things that affects some people yet works fine for others.


Can I nick that for a sig? :D

I gave up on that java search applet a _long_ time ago. IIRC, on the old forums there was a workaround involving copying it onto hd and chmod, but that didn't work for me either.
mugstar
LXF regular
 
Posts: 184
Joined: Mon Apr 11, 2005 12:43 am
Location: Scotland

RE: Re: RE: no search on lxf dvd

Postby hendrik » Thu Apr 21, 2005 5:25 am

So it's not me myself that causes this problem?

Of coarse i know that it's not me, it worked up to the september 2004 issue (LXF57) and after that it starts giving the problem. It is something that has changed the index.tar.gz file. Nelz: if a problem occurs on totally different machines with totally different OSes and different Java versions running you still call it bad luck? :wink:
hendrik
 
Posts: 7
Joined: Sun Apr 17, 2005 6:02 am

RE: Re: RE: no search on lxf dvd

Postby nelz » Thu Apr 21, 2005 8:40 am

The format of the index file and the Java program that uses it haven't changed for years. Does search on the older discs still work for you? I wonder if this may hhave something to do with Java security settings.

If it occurs on everythin, it's easier to fix. when it only affect some people, I call it a variety of things :evil:
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8553
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby hendrik » Fri Apr 22, 2005 5:26 am

Yes, the ones that worked still work, with Java 5, Firefox, SuSe 9.2, Mandrake 10.1, Wni XP, Win 98... do you need more?

Issues later than LXF57 do not work.

hendrik
hendrik
 
Posts: 7
Joined: Sun Apr 17, 2005 6:02 am

Postby nelz » Fri Apr 22, 2005 8:01 am

So 57 works and 58 doesn't. The program hasn't changed, so it must be something in the index file. Either something on that month's disc was added that screwed the format or it just got too big. I'll take a look.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8553
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby hendrik » Sat Apr 23, 2005 5:05 am

Yes, it must be the index file, i have copied the program and index file from 57 to HD, where it works fine and then overwritten the indexfile with the one from 58 or later and then i get the same error message.

thanks, Nelz
hendrik
 
Posts: 7
Joined: Sun Apr 17, 2005 6:02 am

Postby hendrik » Sun Jun 19, 2005 9:10 am

Nelz,

having a hard time solving this problem? ... have you given up?
hendrik
 
Posts: 7
Joined: Sun Apr 17, 2005 6:02 am

Postby nelz » Sun Jun 19, 2005 4:24 pm

No, but there were some other priorities, sorry. I'll see what can be done.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8553
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby pmilne » Fri Jul 22, 2005 8:28 pm

I have this problem also - DVD 69 & 70 - have tried different java versions - 1.4 & 5.0 on Mandrake 9.2
User avatar
pmilne
 
Posts: 18
Joined: Fri Jul 22, 2005 8:03 pm

Postby nelz » Fri Jul 22, 2005 11:20 pm

Sorry, I never got a chance to fix this, so you'll have to hassle Mike to do it now.

I suspect it's something in the index file from DVD58.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8553
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby M-Saunders » Sat Jul 23, 2005 8:54 am

I've never been able to get the search applet to work on anything -- Linux distros with Sun's Java (various release), Windows with Microsoft's version in IE, etc. It always complains about being unable to read the XML file. I did speak to Rich Drummond about it, and he wrote the applet a few years ago so perhaps it's a problem with new Java releases.

I think it's something we should either have fully working, or take a different approach, so I'd like to ask readers: does it work for you? And either way, could you please let me know which Java you're using so I can maybe pinpoint the problem? Thanks!

Mike
User avatar
M-Saunders
LXF regular
 
Posts: 2893
Joined: Mon Apr 11, 2005 12:14 pm

Postby nelz » Sat Jul 23, 2005 9:43 pm

The permissions error appears to be related to Java security settings.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8553
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Postby pmilne » Sat Jul 23, 2005 11:20 pm

I've tried:

java version "1.4.2_03"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.4.2_03-b02)
Java HotSpot(TM) Client VM (build 1.4.2_03-b02, mixed mode)

and

java version "1.5.0_01"
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_01-b08)
Java HotSpot(TM) Client VM (build 1.5.0_01-b08, mixed mode, sharing)

Both versions reported "error parsing index file"
User avatar
pmilne
 
Posts: 18
Joined: Fri Jul 22, 2005 8:03 pm

Next

Return to Magazine and coverdiscs

Who is online

Users browsing this forum: No registered users and 1 guest

cron