Mono - problem on changing to runtime version 2.0

Code junkies hangout here

Moderators: ChrisThornett, LXF moderators

Mono - problem on changing to runtime version 2.0

Postby johndudley » Sat Jan 27, 2007 11:53 pm

As per LXF88 page 94 I have swapped over the Project>Options runtime option to 2.0 from 1.1.

After doing this whatever changes I make to the code don't seem to be saved. If I run the application I just get back the output I have before any changes were made.

If I switch back to 1.1 then it works again but then of course fails when I try to introduce any of the .NET 2.0 functionality.

I haven't been able to find any reference elsewhere to this problem. Can anyone help?

I am running Ubuntu Feisty Herd 2. The mono version seems to be 1.22. The monodevelop version is 0.12

Thanks for any help as this leaves me completely stuck.

John
johndudley
 
Posts: 36
Joined: Tue Jun 06, 2006 11:15 am

RE: Mono - problem on changing to runtime version 2.0

Postby tjelle » Sat Feb 03, 2007 2:00 pm

I had similar experience with ubuntu edgy.
The links below solved my problem:
http://www.linuxformat.co.uk/index.php? ... 7992#37992
http://ubuntuforums.org/showthread.php?t=348140

In short, try the command:
sudo apt-get install mono-gmcs

Hope that helps.
tjelle
 
Posts: 10
Joined: Fri Jan 19, 2007 5:28 pm

Postby johndudley » Thu Feb 08, 2007 3:35 pm

That does the job!

Many thanks.

John
johndudley
 
Posts: 36
Joined: Tue Jun 06, 2006 11:15 am

Postby Hudzilla » Tue Feb 27, 2007 2:58 pm

Just as a point of interest: gmcs is the 2.0 version of mcs, the Mono C# compiler. The two were split to avoid compromising the stability of mcs during the development of 2.0 support, but gmcs came together pretty quickly and so is the better compiler. The two have been merged in newer builds; you just need "mcs" now from 1.2 onwards.
User avatar
Hudzilla
Site admin
 
Posts: 265
Joined: Mon Apr 04, 2005 11:52 am
Location: LXF Towers


Return to Programming

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests