Monodevelop Runtime 2.0 doesn't complie

Code junkies hangout here

Moderators: ChrisThornett, LXF moderators

Monodevelop Runtime 2.0 doesn't complie

Postby moeFinley » Sun Jan 28, 2007 4:53 pm

I using Edgy and Monodevelop 0.12

I have an application that compiles and runs fine using runtime version 1.1 but as soon as I switch to 2.0 it would create an .exe

There are no errors when it compiles but when I try and run it I get
Code: Select all
cannot open assembly

and there is not .exe in the output folder?

I'm just starting to learn Mono so I'm sure I might be doing something wrong but I don't know what. Could any help shed any light? Thanks
moeFinley
 
Posts: 4
Joined: Sun Jan 28, 2007 4:44 pm

RE: Monodevelop Runtime 2.0 doesn

Postby tjelle » Fri Feb 02, 2007 5:20 pm

I got the same problem (ubuntu 6.10 edgy), when trying out the mono tutorial in LFX88.

Was wondering if it had to do with the version of mono installed on ubuntu: mono (1.1.17.1-1ubuntu7.1)?

Does anyone know?
tjelle
 
Posts: 10
Joined: Fri Jan 19, 2007 5:28 pm

Postby moeFinley » Fri Feb 02, 2007 6:57 pm

Sorry, someone posted the solution on the Ubuntu Forums and I should have duplicated it here. You need to install the 2.0 complier.

Code: Select all
sudo apt-get install mono-gmcs


Here is a link to the Ubuntu Forums Post
http://ubuntuforums.org/showthread.php?t=348140

Hope this helps
moeFinley
 
Posts: 4
Joined: Sun Jan 28, 2007 4:44 pm

Postby tjelle » Sat Feb 03, 2007 1:05 pm

Thanks, it works now. :)
tjelle
 
Posts: 10
Joined: Fri Jan 19, 2007 5:28 pm


Return to Programming

Who is online

Users browsing this forum: No registered users and 0 guests

cron