Unable to stop banners from printing

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

Unable to stop banners from printing

Postby mattohope » Tue May 31, 2005 2:30 pm

Hi All,

I know Solaris is not Linux but i'm still hoping someone can help me, after all they are both UNIX based :D

I've added a new printer to a Solaris 8 Server and I can't seem to stop the baner page from appearing with each print job.

The printer in question is called itlaser2, I have tried to turn off banners using lpadmin, lpadmin -p itlaser2 -o banner=never, but it keeps appearing!!!

I can specify nobanner whilst printing, lp -ditlaser2 -onobanner <filename>. However this is not good enough as I don't want the users to be forces to issue this option every time they print a document.

The old Laser Printer, itlaser, works fine, everytime a job is sent to it no banner is produced. Unfortunatly this was setup before my time.

I thought about adding a alias to the users login scripts so the -onobanner is added automatically, alias lp='lp -onobanner'. I would prefer to resolve the issue instead of hiding it though.

Incidentally I've added the same printer to three of out Linux Servers and they print everything without the banner, very annoying.

Any help would be greatly appreciated
mattohope
 
Posts: 4
Joined: Tue May 31, 2005 2:20 pm

RE: Unable to stop banners from printing

Postby Nigel » Tue May 31, 2005 4:42 pm

IIRC this is controlled by a checkbox in the printer setup bit of admintool... will boot up my Sparc later tonight and check for sure.

However, admintool just updates /etc/printcap, so you could go take a look at that file & see what the difference is between itlaser2 & itlaser, and manually edit it (take a backup of the file first !!!)
Hope this helps,

Nigel.
User avatar
Nigel
LXF regular
 
Posts: 1141
Joined: Fri Apr 08, 2005 8:03 pm
Location: Gloucestershire, UK

RE: Unable to stop banners from printing

Postby Nigel » Tue May 31, 2005 6:55 pm

OK, have had a look on my Ultra-5, and yes, there is a checkbox for banners in the printer setup part of admintool. But, only for local printers, not network ones. Network printers seem to inherit the settings from whichever Solaris box they are defined as local to.

In Solaris 8 it isn't /etc/printcap that controls the printers any more (sorry, it used to be with Solaris 2.3). They are defined under /etc/lp/printers with a directory for each printer name. Inside this are various files, including one called "configuration". If you edit this file you should see a parameter called Banner, which seems to have a parameter of "on" for always printing a banner or "optional" if you tell admintool you don't always want a banner. I'm guessing that "off" might work too. Maybe that can be edited by hand for a network printer.

I can't test anything out unfortunately as I can't figure out how to get the Sparc to talk to my networked Color LaserJet 5 - it only seems to want to talk to local printers or those that are local to other SUNs. And it also only seems to want to know about Postscript printers.

By the way, can anyone recommend a good lightweight browser for Sparc/Solaris-8 ? Netscape 4 was taking 5 minutes plus per page to totally mangle this site - I couldn't get the text box to type my message into, so I gave up and moved to the Linux box instead.
I suppose it's what I should expect from an Ultra-5 with only 384Mb memory (it only had 32Mb when I bought it !!!)
:roll:
Hope this helps,

Nigel.
User avatar
Nigel
LXF regular
 
Posts: 1141
Joined: Fri Apr 08, 2005 8:03 pm
Location: Gloucestershire, UK

RE: Unable to stop banners from printing

Postby mattohope » Wed Jun 01, 2005 9:26 am

Hi Nigel,

I've just tried the above and still no joy, it appears that the, lpadmin -pitlaser2 -onobanner, command actually resets the value in /etc/lp/printers/itlaser2/configuration to "Banner = no".

I've also tried creating a copy of /usr/lib/lp/model/standard, calling it standars-nobanner, and editing the lines that read "nobanner=no" to "nobanner=yes". Then setting this file as the printer interface by issuing the following command, lpadmin -pitlaser2 -m standars-nobanner. the configuration file now looks like this:
Banner: off
Content types: simple,postscript
Device: /dev/null
Interface: /usr/lib/lp/model/standard-nobanner
Printer type: hplaser
Modules:
Options: dest=192.168.12.235,protocol=bsd

But i still get banners!!!
mattohope
 
Posts: 4
Joined: Tue May 31, 2005 2:20 pm


Return to Help!

Who is online

Users browsing this forum: No registered users and 5 guests