windows fonts

The place to post if you need help or advice

Moderators: ChrisThornett, LXF moderators

windows fonts

Postby Spangwiches » Sat Oct 29, 2011 8:09 am

I have to have windows fonts for work (making websites). But having them installed makes the web look horrific, they don't get smoothed well and they just look nasty.

So I want a way to toggle between them being there and them not. I believe I can install fonts to a ~./fonts directory, is this still true? Then if I write a script which toggles the name of that folder and rescans/rebuilds the cache/whatever's needed then I guess that'd work?

Seems a bit convoluted though and I just wanted to check: Am I missing a simpler way to do this?
User avatar
Spangwiches
 
Posts: 81
Joined: Thu Sep 22, 2011 2:50 am

Postby Spangwiches » Sat Oct 29, 2011 8:29 am

Well, it seems to work at least...

Code: Select all
#! /bin/bash
if [ -d /home/drew/.unfonts/ ]; then
   mv /home/drew/.unfonts/ /home/drew/.fonts/ && fc-cache -vf
   echo win fonts active
else
   mv /home/drew/.fonts/ /home/drew/.unfonts/ && fc-cache -vf
   echo win fonts removed
fi
exit
User avatar
Spangwiches
 
Posts: 81
Joined: Thu Sep 22, 2011 2:50 am

Postby ajgreeny » Sun Oct 30, 2011 9:36 pm

Just out of interest, which distro is this? I am aware that the difference in font rendering between distros is enormous, but it can be improved relatively easily in most cases.

For example font rendering in Linux Mint LMDE is appalling in comparison with The Ubuntu based Linux Mint, or at least it was when last I looked at LMDE. There was a workaround I read about, but by that time I had moved on from LMDE to lookm at something else. I offer this info to you just in case it is of any help.
Xubuntu 12.04 user, and loving it!
ajgreeny
LXF regular
 
Posts: 462
Joined: Wed May 10, 2006 8:18 pm
Location: Oxfordshire.

Postby Spangwiches » Sun Oct 30, 2011 11:13 pm

This has been niggling at me across various distros (Debian, Ubuntu, Mint, Fedora... probably others). I'm on Arch now though (and planning to say :D ).

Font rendering in Linux is ok now generally, far better that it was a few years ago.

It's just the fonts from the ms-fonts package render particularly badly (really visible on the 'k' of verdana on the body text of web pages for example. Arial is also bad and since many many sites specify 'Arial, sans-serif' or 'Verdana, sans-serif' they tend to get used a lot).

So yeah, it's just those particular fonts which look terrible, the web looks great without them (I actually prefer a lot of the Free fonts). I just need to have them around for work.
User avatar
Spangwiches
 
Posts: 81
Joined: Thu Sep 22, 2011 2:50 am

Postby roseway » Mon Oct 31, 2011 6:20 am

In Firefox (and similarly in other browsers I expect) there's a preference option labelled "Allow pages to choose their own fonts, instead of my selections above", and I always have that unticked. So although I have the MS fonts installed, I never experience the problem described here.
Eric
roseway
LXF regular
 
Posts: 450
Joined: Thu Jan 18, 2007 2:27 pm

Postby Spangwiches » Mon Oct 31, 2011 11:20 am

Thanks roseway. I don't see an equivalent option in Chromium, unfortunately.

Also I'm not sure I want to completely override website authors' choices, just to blacklist certain fonts.

Nice idea though, thanks.
User avatar
Spangwiches
 
Posts: 81
Joined: Thu Sep 22, 2011 2:50 am

Linux & Ms fonts

Postby Hopper » Sun Sep 09, 2012 12:08 pm

For an example of my problem I'll use calibri font and i can replicate this in any of the buntu or buntu based distros. I'm using Mint Maya Cinnamon but haven't tested this problem in non-buntu distros. The calibri font looks dreadful and scratchy in any document I create or open in Libre office or abiword at zoom levels of less than about 100%. However, the printed document is unaffected and prints perfectly regardless of how it looks on screen. I'm sure that it's not an nvidia driver problem since the problem remains when I'm using the free neuveux driver instead. However, just by chance I increased the zoom level on my document to 120% and the document is properly rendered on the page. In other words the problem is a bit of an illusion and only renders incorrectly on the display at low zoom levels (try 75% for instance).
Rig from 2009: Asus P5N7A-VM Mobo with onboard NVidia Geforce 9300 graphics, 4GB Ram, E7500 Dual Core Processor,
Hopper
 
Posts: 6
Joined: Thu Aug 09, 2012 6:19 am


Return to Help!

Who is online

Users browsing this forum: No registered users and 2 guests

cron