Mea Culpa![SOLVED]

Discussion topics, Linux related - not requests for help

Moderators: ChrisThornett, LXF moderators

Mea Culpa![SOLVED]

Postby DavidMcCrossan » Thu Jun 16, 2011 9:19 am

Mint failed to Quit, and after much provocation, I searched thro´me piling system to find words of wisdom from those who know more.

¨Hold down Alt & SysRq & press R,E,I,S,U & B in turn¨.

So I did. I got a screen full of dire imprecations re: the Kbd - all too fast for me to make sense.

Then I was presented with a terminal ¨/home not ready yet or not present¨. I was offered Skip or Manual recovery which both told me after a while that I could not logon since there was no ./ICE with which to check the password.

I could have attempted a boot disk rescue if I had the knowledge and confidence but opted instead for a G & T and re-install from Mike´s excellent dvd.

I don´t think I had caps lock on when I typed the magic sequence. Would this have made any difference? During the night I remembered the BUSIER reversed sequence. Would that have made any difference?

What thinkest?

Best

David
DavidMcCrossan
LXF regular
 
Posts: 345
Joined: Fri Aug 19, 2005 9:46 am

Mea Culpa! - and more...

Postby DavidMcCrossan » Thu Jun 16, 2011 11:10 am

Newly reinstalled Mint 10 will not Quit. Again.

This time I tried REISUB in upper and lower case.

I also changed my user setting from Custom to Root (temporarily).

No difference.

Sytem logs and Dmesg show nothing untoward, except there is no mention of a Quit command.

The Mintsystem log shows mintsystems stopped about 30 mins before I tried to log out.....

I managed to suspend for an hour, but that is far as it goes.

Natch I will post the history on the Mint Forum, but I would much appreciate any help or guidance.

Best

David
DavidMcCrossan
LXF regular
 
Posts: 345
Joined: Fri Aug 19, 2005 9:46 am

Postby nelz » Thu Jun 16, 2011 11:54 am

The Magic SysReq keys only work if the option is enabled in the kernel. Maybe the Mint devs consider their system so stable the feature is unnecessary :roll:

You may be able to check if is is enabled with

Code: Select all
zgrep SYSRQ /proc/config.gz


If it says "CONFIG_MAGIC_SYSRQ=y" the facility is there, assuming that support for /proc/config.gz is built into your kernel.
"Insanity: doing the same thing over and over again and expecting different results." (Albert Einstein)
User avatar
nelz
Site admin
 
Posts: 8552
Joined: Mon Apr 04, 2005 11:52 am
Location: Warrington, UK

Mea Culpa!

Postby DavidMcCrossan » Thu Jun 16, 2011 2:16 pm

Thanx Neil

It sez no such file/dir.

It ain´t your fault.

Best

David
DavidMcCrossan
LXF regular
 
Posts: 345
Joined: Fri Aug 19, 2005 9:46 am

Postby RedWillow » Thu Jun 16, 2011 2:44 pm

Well... In Ubuntu 11.04:

Code: Select all
$ zgrep SYSRQ /proc/config.gz
gzip: /proc/config.gz: No such file or directory


... and the magic key REISUB definitely does work. Doesn't Mint use the stock Ubuntu kernel anyway?

@DavidMcCrossan, I had one machine (or it might have been the keyboard that was the issue) where Alt-SysReq + letter keys didn't work, but AltGr-SysReq did. Try the AltGr key on the right of the space bar instead of Alt.
RedWillow
LXF regular
 
Posts: 719
Joined: Thu May 29, 2008 1:05 pm

Mea Culpa!

Postby DavidMcCrossan » Thu Jun 16, 2011 3:41 pm

Thanx Willow.

I did as you said, but I forgot to set caps lock on. Anyway it dumped me into a screen full of feedback, ending with a blinking cursor. I repeated 2 times more, with the same result.
I gave it the 3-fingered salute and it restarted normally, which is why I am to respond so quickly.

Whether it will quit is another matter for later.

Many thanks

David
DavidMcCrossan
LXF regular
 
Posts: 345
Joined: Fri Aug 19, 2005 9:46 am

Postby RedWillow » Thu Jun 16, 2011 5:58 pm

You don't need caps lock on. In fact the magic key sequence is meant to use the reisub keys, not REISUB, as far as I understand. Or at least unshifted character keys work for me. Also - I found that Ubuntu sometimes doesn't respond to the b=reboot key at the end of the sequence, so I usually do r-e-i-s-u-o, to shut down. Then wait a few moments and use the hardware start button to boot up again.

Last thing - you need to leave a couple of seconds between each. Hold Alt-Gr+SysReq down. Then R - wait - E - wait - I - wait, and so on.
RedWillow
LXF regular
 
Posts: 719
Joined: Thu May 29, 2008 1:05 pm

Mea Culpa!

Postby DavidMcCrossan » Thu Jun 16, 2011 8:32 pm

Willow

I cannot tell you how much I appreciate your help. Light at the end of the tunnel, indeed!

I may have found a work-around.

Request Quit and settle for Hibernate. I live in Spain and the indoors temp in here is now 27 Deg C (at 2200). So fire is a consideration when contemplating leaving hardware working during the day - and unattended.

I purposely left some apps open this evening and they are not open after reopening what I would suppose is a ¨suspended¨ session. I wonder if I have a KBD prob? However, I select the Quit function via the mouse.

USB is not PnP, so I wonder if I could change the KBD while the Beast is asleep. Then try the mouse? Would it damage the interface if I swap devices whilst it is asleep, that is my concern.

I have posted on the Mint Forum but encountered hostility from a ¨jobsworth¨ monitor who to took exception to 2 posts for the same prob. I explained that the second post was further info to help others to help me. Natch I have apologised, but it makes one wonder whether the important function is to criticise the Newbie´s approach to the prob is more important that solving it.

Linux Mint are clearly not concerned about a possible Quit issue. Of course it could be a local hardware issue, but the initial feedback is poor.

In the meantime. thank goodness for people such as you are prepared to give time and expertise to help others who are trying, such as OAPś.

Bless

David
DavidMcCrossan
LXF regular
 
Posts: 345
Joined: Fri Aug 19, 2005 9:46 am

Re: Mea Culpa!

Postby RedWillow » Thu Jun 16, 2011 10:24 pm

A friendly piece of advice. And I mean it kindly.

DavidMcCrossan wrote:I have posted on the Mint Forum but encountered hostility from a ¨jobsworth¨ monitor who to took exception to 2 posts for the same prob. I explained that the second post was further info to help others to help me. Natch I have apologised, but it makes one wonder whether the important function is to criticise the Newbie´s approach to the prob is more important that solving it.


I found your posts on the Mint forum. In fact it would appear that you started two threads within a few minutes of each other, which were then merged by a moderator. You may have made a mistake, intending to add to your original thread, but starting two different threads on the same subject is considered bad form in any forum, including this one. People post to one, not knowing of the existence of the other. It is very annoying for those trying to help.
RedWillow
LXF regular
 
Posts: 719
Joined: Thu May 29, 2008 1:05 pm

Postby Ram » Thu Jun 16, 2011 10:29 pm

Can you log out ? are you then able to shutdown.

Have you tried issuing shutdown cmd from a terminal.

man shutdown for options.

I use to have a issue with ubuntu where it was not releasing the network and hanging on shutdown - try switching of / disconnecting your connection prior to quitting.

lubuntu LXDE 13.10 running on AMD Phenom II*4; ASUS Crosshair III Formula MB; 4 GB Ram.....
User avatar
Ram
LXF regular
 
Posts: 1682
Joined: Thu Apr 07, 2005 9:44 pm
Location: Guisborough

Postby PCNetSpec » Fri Jun 17, 2011 2:10 pm

Is this a Toshiba laptop by any chance ?

My 2 Toshiba laptops require AltGr+SysReq reisub

Alt+SysReq reisub doesn't work.
WARNING: You are logged into reality as 'root'... logging in as 'insane' is the only safe option.
Linux in the UK
The Linux Community Forum
User avatar
PCNetSpec
LXF regular
 
Posts: 631
Joined: Sun Feb 21, 2010 3:50 pm
Location: Cornwall UK

Mea Culpa!

Postby DavidMcCrossan » Fri Jun 17, 2011 4:33 pm

Thanks also to Willow (Noted!) and also to RAM and PCNETSPEC.

Last night I was able to Quit normally!

I use an Acer Aspire desktop.

When I am unable to Quit I am also unable to logout.

I will get man shutdown and try it out in due course and report back.

Many thanks to who have tried to help me so unselfishly.

Best

David
DavidMcCrossan
LXF regular
 
Posts: 345
Joined: Fri Aug 19, 2005 9:46 am

Mea Culpa!

Postby DavidMcCrossan » Sun Jun 19, 2011 2:49 pm

Red Willow, you are a star indeed!

A 1-page printout of man shutdown and a quick practice led to:

Code: Select all
# shutdown -P now

led to a quick and total switch off, with full powerdown.

Exactly what I wanted. Note the root permission.

Thank you so much to all who offered help.

Mark this as SOLVED!

Best

David 
DavidMcCrossan
LXF regular
 
Posts: 345
Joined: Fri Aug 19, 2005 9:46 am


Return to Discussion

Who is online

Users browsing this forum: No registered users and 1 guest